Questions and Answers

Have a travel related question? Post it here, and I’ll do my best to answer it as quickly as possible.

While anyone can comment on regular blog post, registration is required in order to post a question in this space. Creating your account is free, and you'll be able to see when your question is answered, as well as like comments from other users. And of course, you'll earn status points for offering helpful answers!

This space is intended to be more of a community as well, so please jump in and share tips!

Filter by:

AA Flagship First Check In LAX

1

Global Entry Conditional Approval

Can you help?
0

Chase BA 10% Discount – Credit to AAdvantage?

1

Daily Emails?

3

QR Lounge access transiting Doha from First to Business

2

Site Feedback

Hot topic, get involved
36

Transiting LHR on a BA First Class/Club Europe Ticket

2

Newsletter

2

How do I deal w extra seat reservation?

3

Password Change

2

Ask a Question

Everyone can read and comment, but you must login to post a new comment.

Answers (4)

British Airways Website Problem for Award Flight Searching

British Airways Website Problem for Award Flight Searching

  1. Anonymous

    Lucky,

    I’ve been trying to use the British Airways website to search for award flight, but continue receiving this error message,

    “Sorry, there’s a problem with our systems. Please try again, and if it still doesn’t work, you might want to try again later.”

    It has been like this for the past few days. Tried different computers and different browsers. No use. Any idea if it’s a universal system problem from them, or is it just me?

  2. MidSouthSkier

    Is it only on one particular route or for any search? If for one route, do you mind sharing the route and the dates?

  3. Gaurav

    Not at my computer right now but I did do a search yesterday so it is working. Have you tried to create another account and searching from there?

  4. TIS

    I got the same error message for whatever route I tried. If it worked for other people (thanks Gaurav), then it is my own problem. I did do some extensive search before this happened, so it might be that the website automatically blocked an account after the search requests reach to a preset number. I’m concerned, though, if that is really the case, then when the website would unblock the restriction on my account. However, it looks like no one else has experienced this, so the answer is unknown. I might need to try to create another account later. Thanks for the suggestion.

Sign in to help answer questions.