Questions and Answers

Have a travel related question? Post it here, and I’ll do my best to answer it as quickly as possible.

While anyone can comment on regular blog post, registration is required in order to post a question in this space. Creating your account is free, and you'll be able to see when your question is answered, as well as like comments from other users. And of course, you'll earn status points for offering helpful answers!

This space is intended to be more of a community as well, so please jump in and share tips!

Filter by:

Alaska Airline Miles – British Airways First Class

2

ANA Mileage Club – Can’t book a ticket for my partner?

1

Mixed class itineraries no longer available on JAL using Alaska Miles

1

LH First award space on partner airlines missing

1

ORD to Italy in style!!

7

recommendation to use amex points

2

Asiana Redemption 2022 x KAL Acquisition

2

IC bora bora 4 night up for grab

1

Newbie searching flights to Thailand with Miles

2

Virgin Atlantic

1

Ask a Question

Everyone can read and comment, but you must login to post a new comment.

Answers (3)

Anyone else not able to book partner awards on AA?

Anyone else not able to book partner awards on AA?

  1. Anonymous

    I’ve been trying to book partner awards via the AA site for flights next June on QF. The award space appears available however when I click through to the next page to find taxes etc, I consistently see the following message:

    The flight you selected is no longer available. Please modify your request.

    I’m getting this for any combination of dates and flights – is anyone else experiencing this?

  2. Anonymous

    @Auspointer — Sometimes American displays phantom space for Qantas, unfortunately. Have you checked to see if the flights are available on the British Airways tool? If so, you should be able to book them by calling American.

  3. Anonymous

    I had a similar issue last night. SYD-HKG in J on QF showed up as available but when I tried to book it I got the same error. Space showed up on BA as well. I even called thinking it was a website issue but the lady I spoke to couldn’t book it from her side either. I waited a few hours and space was finally bookable at about 01:30am EST.

Sign in to help answer questions.