Questions and Answers

Have a travel related question? Post it here, and I’ll do my best to answer it as quickly as possible.

While anyone can comment on regular blog post, registration is required in order to post a question in this space. Creating your account is free, and you'll be able to see when your question is answered, as well as like comments from other users. And of course, you'll earn status points for offering helpful answers!

This space is intended to be more of a community as well, so please jump in and share tips!

Filter by:

Remaining Chase 5/24 slots

1

Transfer CapOne points

1

Citi Prestige Card No longer accepting application

1

Amex Gold offers free Clear membership

Can you help?
0

Hilton hotel adds surcharge for using a credit card

1

Am I Better Off Earning 4x Amex Points or 5x Citi/Chase Points?

2

Thoughts on Bilt, the new credit card that rewards you for paying rent?

1

iPhone Outright Purchase

Can you help?
0

100,000K Marriott points or 3 free nights?

3

Chase reserve medical evacuation benefit

3

Ask a Question

Everyone can read and comment, but you must login to post a new comment.

Answers (1)

Avios signup points forfeited due to non-US Exec Club address

Avios signup points forfeited due to non-US Exec Club address

  1. Anonymous

    Has anyone ever encountered this problem? I signed up for the BA Chase card, met the spending threshold and earned 50000 bonus Avios plus 4000 for spend. However, when I linked my Chase card to my Exec Club account, it still listed my foreign (non-US) address. Chase told me the 54000 miles would be forfeited even though I updated my address to my US address with Executive Club after the miles were not transferring. It is in the fine print but no one on Chase’s end will be reasonable about it even though I explained I actually live in the US, had my Exec Club account open when I lived overseas and simply didn’t update the address (which i think is a reasonable oversight in the the digital age when statements all come electronically). Anyone ever had this issue and successfully resolved it?

Sign in to help answer questions.